BE100 Deluxe high pitched whistle

Jon BCN

Active member
I have received a BE100 Deluxe and straight out of the box the HBE channel it's pretty much unusuable because it has this really unpleasant high pitched whistle all the time. The more you turn the volume up, the more unbearable it gets.

Only when I hit the strings the whistle stops, but otherwise it's all the time there.
 

sytharnia1560

Well-known member
sounds like guitar pick up to me. Have you normally use high gain in the past? is your pick up a gibson 500t haha
 

Shift65

New member
Agree with sytharnia1560, probably a PU issue.
I have a Friedman WW20 and my HSS American Strat does this when using the bridge humbucker, even when the gain is nearly off.
My stock thinline tele and Charvel with humbuckers do NOT do this, even at maximum gain.
 

Jon BCN

Active member
sounds like guitar pick up to me. Have you normally use high gain in the past? is your pick up a gibson 500t haha

I had a regular BE100 before and it didn't made that noise at all.

My guitar is a Gibson Flying V 67 Custom Shop, as far as I know the pickups are “custombuckers”.

At the end I returned the amp because it wasn't exactly what I wanted, but they told me it was probably a microphonic preamp tube.
 

mentoneman

Well-known member
like this?


i've encountered this from time to time with my mojave peacemaker when i sit too close to it, and coincidentally, my friend's SS v1 does this on the lead boost mode.
 

Jon BCN

Active member
like this?


i've encountered this from time to time with my mojave peacemaker when i sit too close to it, and coincidentally, my friend's SS v1 does this on the lead boost mode.

Yeah, it was similar to that noise.

But only happened in the HBE channel.
 
Top