Rig-Talk

Guitars, Gear, Tone!
It is currently Sat, Apr 04, 2020 4:21pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
PostPosted: Mon, Mar 23, 2020 8:57pm 
Offline
Plank Cranker Trainee

Joined: Mon, Oct 29, 2012 3:19pm
Posts: 399
Location: Riverside, CA
Are you human?: 951
Having a hard time with certain pedals in the fx loop. My Empress Echosystem sounds great... it has a mix and output control (which are the reasons why I think this pedal works so well with this amp) and on the Savage I have the fx loop knob at noon. When I use my Suhr Alexa chorus it sounds horrible - loss of high end and considerable volume drop. The same chorus pedal sounds great through other amps’ fx loops. Please help!


Top
 Profile  
Reply with quote  
PostPosted: Thu, Mar 26, 2020 4:06pm 
Offline
Plank Cranker Trainee

Joined: Mon, Oct 29, 2012 3:19pm
Posts: 399
Location: Riverside, CA
Are you human?: 951
Update...now have the mix knob at 100% per recommendation, problem persisted.


Top
 Profile  
Reply with quote  
PostPosted: Fri, Mar 27, 2020 4:21pm 
Offline
Plank Cranker
User avatar

Joined: Fri, Sep 11, 2015 1:30pm
Posts: 891
Location: Jerkovski, on the Dutch-Polish border...
Are you human?: 951
Can you try the following?
Lower the channel volume(s) and raise the master, see if the problem persists?

With my Savage 60 and Invader I typically run channel volumes around 1 or 2 'o clock and the master very low (around 8), but when I had an SE EL34, I noticed the same as you describe; loss of high-end and 'aliveness' in the fx-loop. Once I ran the channel volumes around 9 'o clock, the problem dissapeared. Don't know why this happens though. :confused:

_________________
Amps:
Engl InVader 100 + Engl 4x12 Pro cab
Engl Ironball + HB 212V cab (G12K85 +V30)
Engl Savage 60 + Two Notes Torpedo Live
EVH 5150 III 50W + Mesa Boogie 2x12 Vertical Slant cab
Fender '74 Princeton Reverb (w/ Eminence Legend 105-8)
Marshall Lead 100 MOSFET + 1966A & 1966B cabs
Mesa Boogie Dual Caliber DC-5 head
Mesa Boogie Mark V:25 + Mesa 1x12 Thiele EVM cab
Roland Jazz Chorus JC-55 combo & JC-120H head
Axes:
Burny Les Paul (3x), Charvel So-Cal, Epiphone Wildkat, ESP Horizon NT-II, Fender '68 RI Strat, Gibson '67 RI Flying V, G&L ASAT Classic Tribute, Ibanez S540FM & Kramer SM-1 Guitars


Top
 Profile  
Reply with quote  
PostPosted: Sun, Mar 29, 2020 12:22am 
Offline
Plank Cranker Trainee

Joined: Mon, Oct 29, 2012 3:19pm
Posts: 399
Location: Riverside, CA
Are you human?: 951
I’ll try that, thanks!!

Speeddemon wrote:
Can you try the following?
Lower the channel volume(s) and raise the master, see if the problem persists?

With my Savage 60 and Invader I typically run channel volumes around 1 or 2 'o clock and the master very low (around 8), but when I had an SE EL34, I noticed the same as you describe; loss of high-end and 'aliveness' in the fx-loop. Once I ran the channel volumes around 9 'o clock, the problem dissapeared. Don't know why this happens though. :confused:


Top
 Profile  
Reply with quote  
PostPosted: Fri, Apr 03, 2020 4:19pm 
Offline
Hack

Joined: Mon, Jan 06, 2020 10:23pm
Posts: 12
Are you human?: 951
What's the outcome, OP? I have an Invader I, but it's loop reads almost the same in the manual. I hooked up a rack effect in my invader's loop, and it sounds fine, but I've never tried any pedals in the loop. The Savage II manual says you can hook up a pedal in the loop too.


Top
 Profile  
Reply with quote  
PostPosted: Sat, Apr 04, 2020 1:22am 
Offline
Plank Cranker Trainee

Joined: Mon, Oct 29, 2012 3:19pm
Posts: 399
Location: Riverside, CA
Are you human?: 951
shadow wrote:
What's the outcome, OP? I have an Invader I, but it's loop reads almost the same in the manual. I hooked up a rack effect in my invader's loop, and it sounds fine, but I've never tried any pedals in the loop. The Savage II manual says you can hook up a pedal in the loop too.


It worked!


Top
 Profile  
Reply with quote  
PostPosted: Sat, Apr 04, 2020 11:23am 
Offline
Plank Cranker
User avatar

Joined: Fri, Sep 11, 2015 1:30pm
Posts: 891
Location: Jerkovski, on the Dutch-Polish border...
Are you human?: 951
Good to hear that.
Strange though that some Engl amps' fx-loops are less picky about the channel volumes.

_________________
Amps:
Engl InVader 100 + Engl 4x12 Pro cab
Engl Ironball + HB 212V cab (G12K85 +V30)
Engl Savage 60 + Two Notes Torpedo Live
EVH 5150 III 50W + Mesa Boogie 2x12 Vertical Slant cab
Fender '74 Princeton Reverb (w/ Eminence Legend 105-8)
Marshall Lead 100 MOSFET + 1966A & 1966B cabs
Mesa Boogie Dual Caliber DC-5 head
Mesa Boogie Mark V:25 + Mesa 1x12 Thiele EVM cab
Roland Jazz Chorus JC-55 combo & JC-120H head
Axes:
Burny Les Paul (3x), Charvel So-Cal, Epiphone Wildkat, ESP Horizon NT-II, Fender '68 RI Strat, Gibson '67 RI Flying V, G&L ASAT Classic Tribute, Ibanez S540FM & Kramer SM-1 Guitars


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group - Terms of Use