Rig-Talk

Guitars, Gear, Tone!
It is currently Mon, May 20, 2019 8:55am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu, Feb 21, 2019 7:06pm 
Offline
Hack

Joined: Sat, Jan 11, 2014 8:06pm
Posts: 7
Are you human?: 951
Man, I really love my 4212. People constantly ask me how I get such great tone, and I tell them the truth. I just plug my Les Paul studio straight into my 4212. For what I play (punk, ska, rockabilly, psychobilly) it is perfect.

However.....

My power plant died back in 2014 (I think). And as most people have experienced Vlad at egnater wasn't helpful at all saying it was a "known issue" however, since the power plant didn't go out on ALL of the tourmaster...they weren't providing replacements for free...I thought it was bs so I posted about it on here and got a PM from Mr. Bruce Egnater. I'm just going to say he was VERY helpful and restored my faith in the brand.

However...

I now have another issue. My tourmaster is in my "jam room" (basement) because I really only use it when I'm jamming with people and since I'm not in a band right now it doesn't get much use.

The other day I fired it up and was TRYING to impress this chick with my fast and accurate fingers 😉 and about 5 minutes into playing all of a sudden it turned off. I smelled a little smoke, but since I had a chick over I just unplugged it and didn't worry about it for a little while.
The first show I played with this amp, I had it tilted against a wall and when I hit my first note it fell over. The outlet that you plug the power cord into broke and split in half. When I got home, I took it apart and kind of rigged it together with electric tape and taped the power cord into it. Hard to describe, but it was janky.
Anyhoo, when it died the fuse was blown so I replaced the fuse, fixed the outlet (or inlet. Whatever it is) and put it together correctly. Put the power tubes in one at a time, firing it up to test them. All good. Put the preamp tubes back in....all good.

SO

I figured it was just a freak thing and was about to put the head back into the cabinet and I noticed THIS.

Image
Image


I am by no means an electronics expert but I can definitely remove this part and solder in a new one but do I need to?? Is this going to effect the amp? And what would cause this to melt?? Do I need to worry that my amp is going to die again??

I hope not because I love my amp and CAN NOT afford a new one. My mom has Parkinson's and requires full time care, and that's what I do and don't get paid for it because she's my f'ing mom and I love her and she took care of me for 20-39 years!!!

Anyway. Does anyone know what's up with this? If I need to replace it, is it a part I can buy somewhere?

Thank you!!!


Top
 Profile  
Reply with quote  
PostPosted: Thu, Feb 21, 2019 9:53pm 
Online
Plank Cranker Wanker
User avatar

Joined: Thu, Apr 15, 2010 5:47pm
Posts: 1726
Location: offline
Are you human?: 951
I would post this in the main forum. Lots of smart people post in there and they might have some idea's for you. I'm not an amp tech and have limited electronics experience but that appears to be capacitor in the power section of the amp and yes it needs to be replaced. The film or insulation has melted. I'd get it to a tech.

Let me see if I can get you started on the cap at least.

Here:

https://www.google.com/search?q=.22+140 ... e&ie=UTF-8

_________________
Fender Fat Strat / Schecter C1+
Splawn Quick Rod and cab / Mesa Rectoverb / Vypyr 60 / Blackheart 1w
A bunch of pedals
Clips
My Blogs



"PEOPLE TRUST ME WITH THEIR LIVES,,,,, THINK ABOUT IT!" - Billy Blades

"I don't let peoples opinion of me rent space in my head, its none of my bidness."- Charveldan

"Mr. Blades is a dickwad, can't play for shit, can't make an amp to save his life and has shit gear.
Dan is largely misunderstood, a great person, a good GP and has excellent gear. Other than that they are nothing alike."
- Charveldan 03/02/16..............AKA: Chester Nimitz


Top
 Profile  
Reply with quote  
PostPosted: Mon, Feb 25, 2019 7:39am 
Offline
Hack

Joined: Fri, Jul 22, 2011 7:05am
Posts: 13
Are you human?: 951
THAT IS NOT A CAPACITOR!!!

That is a thermistor. It's purpose is to prevent sudden large inrush currents from blowing your fuse, or damaging any other internal components. From your picture, it looks to be an SL22 14007.

https://www.mouser.ca/ProductDetail/Ametherm/SL22-14007?qs=PVyXUKBeRH0P1w064d1OhA==

That fact that it's burnt to a crisp indicates two possibilities; it did it's job, and protected you amp, and/or there's a deeper problem with your amp. Perhaps a problem with a tube, cap or caps, or the transfo itself. A thermistor is not meant to burn up like that, unless it's severely overloaded. It limits the inrush current for a short period of time (milliseconds) until everything stabilizes. Generally, the big inrush occurs when the big caps in the power section are charging up at power on. This especially after the amp has sat idle for a day or two, the caps having discharged. It will happily do this for certain period of time, or until it is overloaded. Get someone competent to look at it.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group - Terms of Use