Rig-Talk

Guitars, Gear, Tone!
It is currently Mon, Oct 26, 2020 8:23am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sun, Aug 23, 2020 1:31pm 
Offline
Hack

Joined: Sat, Jun 30, 2018 7:50pm
Posts: 9
Are you human?: 951
Plugged into my amazing BE-50 amp and the sound suddenly is tinny with no dynamics. Clean channel sounds normal. Went through diff guitars, cables and channels still the same. Does it sound like a tube or something worse?


Last edited by Screenbuzz on Sun, Aug 23, 2020 2:33pm, edited 2 times in total.

Top
 Profile  
Reply with quote  
PostPosted: Sun, Aug 23, 2020 1:56pm 
Offline
Supah Stah
User avatar

Joined: Fri, Jun 10, 2016 9:08am
Posts: 2679
Location: Near beer
Are you human?: 951
Once you've eliminated things external to the amp like cables/guitar/speakers or something in the FX loop then suspect tubes first. Preamp tubes are easy to swap out and verify operation, just do one at a time and if it's not that tube put the old good tube back in and check another.

_________________
Mesa Mk IIC+ SRG; Mesa Traditional 4x12 w/V30
Marshall 100W Superbass*; Marshall '78 1960A w/G12M-25
Marshall 50w Smallbox Jose*; Marshall '84 1960A w/G12T-75
Fender BF Bassman*; Armadillo Bluesbreaker 2x12 w/EV-12L
Trainwreck Rocket*; Carvin Tweed 1x12 w/G12-65
'13 Gibson LP Std CSB
'17 Chubtone TS Vintage Cream Nitro #0037
'17 D'Avanzo Cheshire Cat Burst 2.0 DA.033
'87 Kramer Focus/Musikraft Strat* (<-avatar)
'03 Warmoth Tobacco-Burst Strat*
* - assembled/modded by me


Top
 Profile  
Reply with quote  
PostPosted: Sun, Aug 23, 2020 4:18pm 
Offline
Hack

Joined: Sat, Jun 30, 2018 7:50pm
Posts: 9
Are you human?: 951
Well I Replaced every pre amp and power tube one by one....still the same...i don't think it's a tube.


Top
 Profile  
Reply with quote  
PostPosted: Sun, Aug 23, 2020 4:33pm 
Offline
Supah Stah
User avatar

Joined: Fri, Jun 10, 2016 9:08am
Posts: 2679
Location: Near beer
Are you human?: 951
One last thing you could try would be to plug a known good cable from Send to Return. If that fixes it then you have a faulty jack. If that isn't it then you might have to take it to a tech.

_________________
Mesa Mk IIC+ SRG; Mesa Traditional 4x12 w/V30
Marshall 100W Superbass*; Marshall '78 1960A w/G12M-25
Marshall 50w Smallbox Jose*; Marshall '84 1960A w/G12T-75
Fender BF Bassman*; Armadillo Bluesbreaker 2x12 w/EV-12L
Trainwreck Rocket*; Carvin Tweed 1x12 w/G12-65
'13 Gibson LP Std CSB
'17 Chubtone TS Vintage Cream Nitro #0037
'17 D'Avanzo Cheshire Cat Burst 2.0 DA.033
'87 Kramer Focus/Musikraft Strat* (<-avatar)
'03 Warmoth Tobacco-Burst Strat*
* - assembled/modded by me


Top
 Profile  
Reply with quote  
PostPosted: Sun, Aug 23, 2020 4:47pm 
Offline
Rock God
User avatar

Joined: Wed, Dec 09, 2009 11:00am
Posts: 9222
Location: Chicagoish
Are you human?: 951
If you can’t get it figure it out just email Dave he’ll walk you through it


Top
 Profile  
Reply with quote  
PostPosted: Wed, Sep 23, 2020 7:32pm 
Offline
Plank Cranker Trainee
User avatar

Joined: Fri, Mar 15, 2013 1:45am
Posts: 508
Location: Central USA
Are you human?: 951
Screenbuzz wrote:
Well I Replaced every pre amp and power tube one by one....still the same...i don't think it's a tube.


Well I hope you didn’t do the power tubes that way!

_________________
Gear: http://equipboard.com/adambomb80
Music: https://soundcloud.com/adamclayton35
https://www.youtube.com/adam614ce
http://www.myspace.com/nilesflow
http://www.myspace.com/adam614ce


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group