Bogner Uberschall Twin Jet with FX loop volume loss

leib10

Active member
My Twin Jet has been experiencing volume loss with the FX loop engaged. This is with the FX loop volume control maxed out and no pedals turned on. Any ideas about what’s going on?
 

Big Rich

New member
I had the problem with mine when i had it. I found out that i needed to keep the channel volum knobs below 11:00 and around 9:00. Adjust the volume with the master and keep the channel volumes around 9:00. See if that does it.
 

maddnotez

Well-known member
Big Rich":1gdnnnus said:
I had the problem with mine when i had it. I found out that i needed to keep the channel volum knobs below 11:00 and around 9:00. Adjust the volume with the master and keep the channel volumes around 9:00. See if that does it.
Guess they have the same loop as the old Uber? No levels.

I thought they updated that with the Rev Blue?

Hopefully thats the issue and nothing else. That TJ is a mean SOB
 

Big Rich

New member
Those had the best loops once tweaked. I really liked that amp when i had it. Sold it for a rev blue which I kept for like 7 years. I liked the rev blue 2nd channel better. The twin jets 1st channel was amazing (the reason to own that amp imo). The uber is one of the best metal amps of all time once you learn how to tweak it. In a room at volume is the only way to appreciate that amp. It has this 3d wall of sound coming out of a cabinet you need to experience in person. You will never capture that experience with vids or clips. Its a playing experience that you can feel. Nothing ive played can recreate the uber thing im talking about. Others that have played it hopefully understand what im talking about haha
 
Top